Pardot Knowledge Base

Why do my Pardot assets like forms and images look broken on my tracker subdomain?

Last Updated: Dec 09, 2015 | Print this Article
 
After creating or updating your tracker subdomain, Pardot-hosted assets like forms and landing pages might look broken or fail to load. You may see broken images in your emails and email templates. This usually happens when your CNAME setup is not forwarding internal traffic on your system to the go.pardot.com-hosted resource. The usual fix is to have your IT team set up the CNAME on your internal DNS.

There are 2 methods for testing whether this is the case: on your internal network, and on an external network.

On the Internal Network

On a device connected to your company's internal network, take the broken or missing page/file/link URL and replace CNAME with go.pardot.com and see if it loads.

For example, if this were your link: http://www2.yoursite.com/l/49802/2015-02-25/m6zp, change it to: http://go.pardot.com/l/49802/2015-02-25/m6zp. If the URL with go.pardot.com loads (even if the formatting looks off), then you'll need to work with your IT team to clear up the CNAME forwarding for internal traffic.

On an External Network

Use a cellphone or other device that's not connected to your company's internal network to visit the original URL. If the asset loads, then you'll need to work with your IT team to clear up the CNAME forwarding for internal traffic.

Need more? Start a conversation with other Pardot users in our Success Community